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1 Introduction
 

Overview of the Guide

This guide provides a detailed description of the Keysight N5991 HDMI
ARC Frame Generator.
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Document History

First Edition (April 2020)

The first edition of this user guide describes functionality of software 
version 1.0.
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HDMI ARC Frame Generator - Overview

HEAC (HDMI Ethernet and Audio Return Channel)

HEAC is an optional feature of HDMI introduced with HDMI 1.4. It reuses 
two lines of the HDMI connector to make possible the set up of a 
Full-Duplex 100Base-Tx Ethernet connection as well as a digital 
IEC60958-1 compliant audio return channel from a sink to a source device.

HEAC’s physical layer is tested by sending Ethernet ARP-Requests with 
worst case signal performance. The software verifies that the device was 
able to receive and understand it by capturing the response data and 
verifying if an ARP-Reply is sent. The audio data is verified by sending 
audio data with worst case conditions, listening to that sound and 
ensuring that it is free from any spurious noise.

eARC (Enhanced Audio Return Channel)

EARC (Enhanced Audio Return Channel) is a new feature of HDMI 
introduced with HDMI2.1. It uses an HDMI connection to send audio from 
TV (HDMI Sink) to whichever device is used to generate sound (Sound Bar 
or AV receiver [HDMI Source]). The eARC feature is the successor of ARC 
(HEAC). The eARC audio transport uses an HPD line for eARC-signals and 
Utility line for eARC+ signals to provide Differential Mode Audio Channel 
(DMAC) and Common Mode Data Channel (CMDC). The DMAC uses a 
differential signal to transmit digital IEC60958-1 audio stream. The CMDC 
uses the common mode signal, which contains control information related 
to the IEC60958-1 audio stream.

eARC’s physical layer is verified by sending differential audio data with 
worst case conditions, listening to that sound and ensuring it is free from 
any spurious noise. Common Mode Communication is bi-directional.

The HDMI ARC software covers physical layer receiver tests for eARC 
Differential Audio and Common Mode Communication between the Test 
Equipment and RX DUT.
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Installing the HDMI ARC software

After you download the installer for the HDMI ARC software, perform the 
following steps:

1 Double-click the installer (.exe) file.

The ‘Welcome’ window is displayed.

2 Click Next.

The ‘End-User License Agreement’ window is displayed.

3 Read the terms of agreement carefully and select the I accept the 
terms of the License Agreement option.

4 Click Next.

The ‘Required Software Components’ window is displayed. The HDMI 
ARC software performs a check if all prerequisite software components 
are installed on the same machine. The required software components 
are:

• Keysight IO Libraries Suite (version 18.0 or higher)

• .NET-Framework 4.7.1 (or higher)

If the software finds that these components are installed, the Install 
button appears grayed out; otherwise, click Install corresponding to 
the required component.

5 Click Next.

The ‘Choose Install Location’ window is displayed. By default, the 
HDMI ARC software is installed in C:\Program Files (x86)\BitifEye\
ValiFrameK1\HdmiArc\DebugTool.

Optionally, click Browse... to change the destination folder.

6 Click Install.

The HDMI ARC software is installed.

7 Click Finish to close the final window that appears at the end of 
installation.

NOTE
The software requires Microsoft Office Excel to generate reports at the 
end of test runs. However, this software component is not available for 
free distribution and requires separate installer and licenses. The HDMI 
ARC installer simply detects and displays the status of whether Excel is 
installed or not.
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After installation is complete, you may view the changelog.txt file to know 
about the enhancements in the installed version of the HDMI ARC 
software. A shortcut to access the software is installed in both the Start 
menu and on the Desktop. 

Double-click the HDMI ARC Frame Generator (N5991) icon (shown in 
Figure 1) to start the software.

Figure 1 Shortcut Icon to launch the HDMI ARC software

The default window of the HDMI ARC software, as shown in Figure 2, is 
displayed.
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Figure 2 Default window of the HDMI ARC Frame Generator software
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Troubleshooting and Support

If you experience issues with the software, send an email to 
hdmi-support@bitifeye.com. You must mention the version number, which 
you can find in the About dialog. To access it, click Help > About... from 
the main menu.

Figure 3 About the HDMI ARC software

Click Help > Show Log File to view the logs that may also help you with 
troubleshooting any issues.
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Required Instruments

The HDMI ARC software enables testing of the receiver physical layer of
the HEAC and eARC.

Instruments required for HEAC testing

Table 1 HEAC testing instruments and quantity

Instruments required for eARC testing

Table 2 eARC testing instruments and quantity

Instrument type Quantity

Keysight 81150A Pulse Function Arbitrary Generator with 
2 channels
• requires Firmware 2.0.1.0 or newer and Pattern 

Option

2

Keysight Real-Time Oscilloscope (either one of the 
following)
• S-series Oscilloscope
• DSOX90000 series or compatible
• DSAVxx4A
• Keysight Infiniium V-series Oscilloscope

1

Instrument type Quantity

Keysight 81160A Pulse Function Arbitrary Generator with 
1 channel
• requires Firmware 2.0.1.0 or newer
• Pattern Option

1

BIT3000 Dynamic Sequencing Generator Analyzer 1

Keysight Real-Time Oscilloscope (either one of the 
following)
• S-series Oscilloscope
• DSO90000 series or compatible
• DSAVxx4A
• Keysight Infiniium V-series Oscilloscope

1
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Setting up connections

HEAC connections

1 Connect the probing points of the physical layer test board with the 
socket probe head and the probe with the Channel configured in the 
HDMI ARC software.

Typically, this connection is differential. Therefore, select the Use 
Differential Probe check box in the Ethernet Analyzer tab.

2 The trigger signal is provided by Channel2 output of the 81150A that 
generates the Ethernet data; connect it with the Trigger Channel 
option selected in the software.

Figure 4 HDMI ARC software settings for HEAC connections

3 Combine the outputs of the 81150As with power combiners and 
connect it to the SMA connectors of the physical layer test board.

4 Connect the Device-Under-Test (DUT) with the physical layer test 
board’s DUT connector by using an HEAC Test Fixture.

5 Connect the secondary HDMI connector with a CEC generator that is 
capable of sending the required CEC messages.

Currently, the software does not provide controls for the CEC 
generator. You must use external methods to control it.
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Figure 5 HEAC connection setup with Generator 1 and Generator 2 (Audio)
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 Figure 6 HEAC connection setup with Generator 1 but no Generator 2 (Audio) 



18 Keysight N5991 HDMI ARC Frame Generator User Guide

2 Test Instrument Setup
 

Figure 7 HEAC connection setup with an RTS (Oscilloscope) Analyzer



Keysight N5991 HDMI ARC Frame Generator User Guide 19

Test Instrument Setup 2

 

eARC connections

The connection setup for Rx eARC and Tx eARC are shown in Figure 8 and 
Figure 9.

Use an external DC power supply to inject the bias voltage (5V) on the 
HEAC board.

Figure 8 eARC connection setup for Rx
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 Figure 9 eARC connection setup for Tx
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Connecting to the Instruments

After launching the software, you must establish connection to the 
instruments.

1 On the main window of the HDMI ARC software, click Connect... on the 
bottom left corner.

Alternatively, from the main menu, click File > Connect....

The Instrument Connection window appears.

Figure 10 Instrument Connection window for HEAC

2 From the Application drop-down options in the Instrument 
Connection window,

a For HEAC testing, select HEAC (default option).



Keysight N5991 HDMI ARC Frame Generator User Guide 23

Using the Software 3

 

b For eARC Rx testing, select eARC. Leave Use eARC Analyzer check 
box unchecked.

c For eARC Tx testing, select eARC. Select the Use eARC Analyzer 
check box.

Figure 11 Instrument Connection window for eARC

3 As required, select the check box for the instruments in the Generator 
1, Generator 2 and Analyzer (Real-Time Oscilloscope) sections.

4 Specify the VISA address in the Address field for the selected 
instruments.

5 After setting the desired configuration, click Connect on the bottom 
right corner of the window.

The software attempts to establish connection to the selected 
instruments and returns to the main window if the connection attempt 
was successful.

Thereafter, the software loads the instrument settings configured 
during the last session to help you avoid configuring instrument 
connection each time you start the software.
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Main window features

The default window of the HDMI ARC software, shown in Figure 12, 
displays various tabs that have parameters required for both HEAC and 
eARC testing.

Figure 12 Default window of the HDMI ARC Frame Generator software

However, after the connection to the instruments has been established, 
the main window shows only those tabs that pertain to the selected 
Application (HEAC or eARC) and the instrument configuration in the 
Instrument Connection window. The functionality of the respective tabs 
are explained in further sections in this document.
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For each configuration, one or more of the following action buttons are 
available at the bottom of the window:

• Connect / Disconnect—Clicking the Connect... button launches the 
Instrument Connection window, which helps you establish connection 
to one or more instruments. The text on the button changes to 
Disconnect after the software is connected to the instruments 
successfully.

• Generate—Clicking Generate applies the settings configured in the 
Generator tab to the data generator.

Alternatively, from the main menu, click File > Generate to perform this 
action.

• Analyze Ethernet—Clicking Analyze Ethernet initiates Ethernet analysis 
and displays the results in the Ethernet Analyzer tab.

Alternatively, from the main menu, click File > Analyze Ethernet to 
perform this action.

• Analyze Audio—Clicking Analyze Audio initiates Audio analysis and 
displays the results in the Audio Analyzer tab.

Alternatively, from the main menu, click File > Analyze Audio to 
perform this action.

The other options available in the File menu are (in the order of usage):

Figure 13 File menu options in the HDMI ARC software

• Save Settings—Save settings from the current session in *.set format.
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• Save as Favorite—Save those settings as favorites that you prefer to 
load quickly without the need to browse for the corresponding *.set file.

• From the File menu, click Save as Favorite....

• On the Save as Favorite dialog box, enter a name for the favorite 
setting of your preference and click Save.

Figure 14 Save as Favorite dialog box in the HDMI ARC software

• Load Settings—Load settings already saved in a *.set file into the 
current session.

• Favorites—View all the settings that have been saved as favorite in the 
current or in one of the previous sessions of the software. Click a name 
to load the settings immediately into the current active session. To view 
the *.set files corresponding to the saved favorite names, click Open 
Favorite Folder. By default, the software saves these files in C:\
ProgramData\BitifEye\ValiFrameK1\HdmiArc\Settings.

Figure 15 Accessing Favorite settings from the File menu

• Exit—It is an alternative option to Close button for exiting the software.
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You may also use keyboard shortcuts to perform some of the actions 
described above.

Table 3 Keyboard shortcuts for certain actions

The options that appear in the Tools menu are explained in “Features in 
the Tools menu” on page 34 of this document.

The options that appear in the Help menu have been explained in certain 
sections of Chapter 1, “Introduction”.

Keyboard shortcut Corresponding action

Ctrl + C Connect / Disconnect

Ctrl + G Generate

Ctrl + E Analyze Ethernet

Ctrl + A Analyze Audio
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Generator

The settings in the Generator tab use either one or two Keysight 81150A 
generators to generate both audio as well as Ethernet data required for 
HEAC testing. The audio data is transferred either in Common mode or in 
Single mode. Single mode transmission is allowed only if no Ethernet data 
is transmitted.

Figure 16 below shows the user interface for the Generator tab, where the 
parameters for Ethernet (100Base-Tx) and Audio Parameters are 
separated. You may either select only the Generate Ethernet data check 
box or only the Generate audio data check box to generate the respective 
data at a time or select both for generating both data types 
simultaneously. If none of these check boxes are selected, the software 
programs the generator output to 0V so that a connection change (such as 
removing power combiners) may be avoided.

Figure 16 Generator tab settings for HEAC testing



Keysight N5991 HDMI ARC Frame Generator User Guide 31

HEAC Rx Testing 4

 

Ethernet (100Base-Tx settings)

The Ethernet tab generates an ARP Request that is broadcast with the 
corresponding information specified in the user interface. If Send Idles 
Only is checked, only Ethernet packet are sent without audio data. If Using 
ISI Traces is checked, the data includes the ISI component in the software. 
The Receiver IP should match the IP address configured on the DUT. In 
addition to these protocol parameters, you can specify some physical layer 
parameters, such as High Level (voltage), Low Level (voltage), Data rate, 
Jitter (sinusoidal) and Transition Time.

The sinusoidal jitter frequency is slightly adjusted by the software prior to 
applying it to the instruments so that the replied data can be analyzed. 
This adjustment is done because the software first captures the reference 
data and subtracts it later on for this purpose. However, the phase of the 
sinusoidal jitter must be aligned with the beginning of the pattern. To 
achieve this, the software adjusts the frequency as a multiple of the 
pattern duration. The transition times can also be adjusted manually to 
allow flattening of the transitions and verifying the ability of the DUT in 
handling slower transitions.

Audio Parameters

The audio part generates audio data, which is IEC60958-1 compliant along 
with audio data, which contains the two frequencies specified in the 
Channel A Freq and Channel B Freq fields. Additionally, you may configure 
the Sample Rate as well as the Sample Size parameters. On the physical 
layer, you can adjust the Amplitude, Offset, Deviation (from the Data 
rate), Trans.Time and Jitter (sinusoidal) fields.

Select the Use Power Divider check box if you wish to use power dividers 
to split the common mode audio signal. By using this option, you can use 
one channel of the 81150 device to generate the audio data and reserve or 
use the second channel for other purposes.

Once you have configured the required parameters, click Generate to start 
the generation of the patterns and to setup the instruments.

NOTE
You may specify custom jitter values by typing into the Jitter field jitter 
amplitude and frequency of your choice. Enter the jitter values in the 
following format: <JitterAmplitude> UI@<JitterFrequency> Hz

You may use unit suffixes, such as kHz, mUI and so on.
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Ethernet Analyzer

Figure 17 shows the default view of the Ethernet Analyzer tab for HEAC 
testing.

Figure 17 Ethernet Analyzer tab settings for HEAC testing

The HDMI ARC software uses a Keysight Real-time Oscilloscope to 
capture data on the HEAC lines. The HEAC specification requires capturing 
and analyzing these data so that it can be verified if the device has 
acknowledged the ARP-Request with an ARP-Reply.

Overview

This method is used to verify if the device was able to receive the 
transmitted data.
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The notable fact about HEAC Ethernet signals is that both devices send 
their data on the same lines. So, the receiver must first subtract its sent 
data to know what the other device is currently sending.

Procedure

The HDMI ARC software performs the verification in two steps.

In the first step, the generator (81150A) sends data with the DUT 
disconnected. In this duration, the software captures the reference signal, 
if the Subtract Reference check box is selected.

In the second step, the DUT is connected and the software captures the 
data again. Now, the software captures the combination of both signals. 
However, with the help of the saved reference data, the software subtracts 
the combined data and obtains that data, which is sent by the DUT.

For the capture process, specify the Sample Rate and memory size (in the 
Nr of Samples field) that must be set on the Oscilloscope. The configured 
values must match the configuration of the Oscilloscope model and 
options you are using. Additionally, you can configure the HEAC+ Channel, 
HEAC- Channel (for single-ended probes) and Trigger Channel fields to 
specify the Channels that are used on the Oscilloscope.

Once you have configured the required parameters, click Analyze Ethernet 
to start the capturing and analysis process. The software displays the 
packets that are found in the Results area (see Figure 18). The Nr of 
Captures field lets you specify the number of captures the software should 
perform.
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Figure 18 Ethernet Analyzer Results

At times, it is possible that the DUT may not respond to some 
ARP-Requests within the duration the capture is performed with the 
Oscilloscope. In such cases, you may not see the ARP-Reply even though 
the device is sending it. As devices typically delay in sending some packets 
only, a workaround to this problem is to setup the Nr of Captures field for 
capturing at least five times (that is, 5 repetitions). Additionally, the 
software automatically adjusts the Trigger Offset value in the repetition 
mode if no ARP-Replies are found within two consecutive captures. During 
the analysis run, the software displays the analyzed packets as soon as 
they are found.

Features in the Tools menu

• Abort Analysis Process—From the main menu, click Tools > Abort 
Analysis Process to abort the process of analysis at any stage.
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• Copy Packets to Clipboard—To export the information associated with 
the found Packet(s) that are displayed in the Results area, click Tools > 
Copy Packets to ClipBoard. The copied data, when pasted into an 
editor (such as Notepad, and so on), is displayed in a CSV 
(Comma-Separated Value) format. An example is shown in Figure 19.

Figure 19 Clipboard data for Results as it appears on a Notepad

• Advanced Analyzer Properties—If you experience issues during the 
process of data analysis, you may have to adjust some of the advanced 
analyzer parameters. Click Tools > Options > Advanced Analyzer 
Options....

The Advanced Analyzer Properties window appears, as shown in 
Figure 20.

Figure 20 Advanced Analyzer Properties window

Here, you can adjust the bit recovery method as well as the thresholds 
and activate an optional low pass filter, as described further.
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• The Bit Recovery Method specifies the method that must be used 
by the software to recover logical value from the sample points 
captured for one bit.

• The default method is CenterValue, which uses the sample 
point in the center of the bit as the bit value. This method is 
very fast but might result in errors due to glitches.

• The second option is WeightedBitValue. This method weighs 
different sample points according to their distance from the 
center of the bit and the sample points in the middle are used 
with the highest factor. The graph plotted below the 
drop-down options illustrates this method’s implementation.

• For the last method, that is MaxOccurrence, the number of 
different logical values is accumulated and the logical value 
with the maximum number of occurrences is used.

• The threshold options enable the software to convert the voltage 
levels to logical values. As Ethernet uses a three-state signal, you 
must specify the two threshold levels (Upper Threshold and Lower 
Threshold). If you select the Use Automatic Thresholds check box, 
the software measures the amplitude of the reference data as well as 
the amplitude of the combined signal. Then, it calculates the 
amplitude of the DUT signal and sets the thresholds to a value 
resulting from (± DUT Amplitude / 4). However, you may uncheck 
the Use Automatic Thresholds and manually define values in the 
Upper Threshold and Lower Threshold fields.

• (Optional) If selected, the Use Low Pass Filter feature helps you to 
reduce glitches captured or calculated while subtracting the 
reference data.

Once you have set up the Advanced Analyzer Properties as per your 
requirements, click Close to exit this window. The software 
automatically uses the modified settings.

NOTE
The parameters shown on this window are not saved in the settings file.
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Audio Analyzer

Figure 21 shows the default view of the Audio Analyzer tab for HEAC 
testing.

Figure 21 Audio Analyzer tab settings for HEAC testing

The HDMI ARC software uses a Real-time Oscilloscope to analyze the 
audio signals. However, the audio data is unidirectional and only 
transmitted from the Sink to the Source. The data rate depends on the 
audio sample frequency and is always 125 MBit/s below the Ethernet 
signal. The software automatically extracts the clock from the data and 
adjust its data rate to the corresponding value. Additionally, the software 
automatically detects the DC offset voltage levels of the different signals 
and ensures that the audio data is recognized correctly.
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Once you have set up the Sample Rate and memory size (in the Nr of 
Samples field) for the Oscilloscope and configured the Channels using the 
HEAC+ Channel and HEAC- Channel, you can start the analyze process. 
The Audio Analyzer tab displays the results in the Audio Results area (see 
Figure 22).

Figure 22 Audio Analyzer tab settings for HEAC testing

The Audio Analyzer tab shows the test results of the audio analyze 
process related to the different sections of the IEC60958-1 specification. 
Test items that passed are shown in green whereas the failed items are 
shown in red. Additionally, the information regarding the audio data is 
shown below the Audio Results tree. This information is extracted from 
the Channel status bits and contains the Sample Freq., Sample Size and 
the Clk Accuracy.
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Beside this data, the value of the audio samples are shown on the right 
side in the Channel A Samples and Channel B Samples fields. You may 
also copy the values from these fields into a different software for further 
processing.
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eARC Rx Testing

Figure 23 shows the tabs that appear for eARC Rx testing, when the 
Application is selected as eARC and the Use eARC Analyzer check box is 
unchecked in the Instrument Connection window.

Figure 23 Default Generator tab settings for eARC Rx testing

Generator

Differential eARC is generated as fixed tones on eight Channels, as shown 
on the left side of Audio Parameters area. If Using ISI Traces is checked, 
the data includes the ISI component in the software. For the audio part, 
the electrical parameters can be adjusted under Audio PHY Parameters 
(to the right). You can either add a pre-selected amount of jitter to the 
signal or type the required amount of jitter directly into the Jitter combo 
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box. Depending on the selected values for the audio’s Sample Rate and 
the Sample Size, when you click Generate, the HDMI ARC software 
calculates the Datarate of the signal.

When you click Generate, the software generates a compliant pattern 
automatically based on the CTS and Specifications. However, you may 
select the Custom Pattern check box in the Pattern area to load a 
customized pattern for differential and common mode signals. SPDIF 
Differential Pattern and SPDIF Common Mode Pattern fields let you 
define the Differential signal bit stream and the Common Mode patterns, 
respectively, as defined in eARC specification. This feature can be used for 
the purpose of debugging.

Common Mode Data Channel provides bi-directional data transfer 
between the eARC TX (DSGA) and eARC RX. Common Mode signal data 
(from eARC TX) is a heartbeat pattern, which is sent along with the 
differential audio data. Before starting the actual Physical layer RX testing, 
eARC discovery is required. The discovery process is triggered by the HPD 
signal on the HDMI cable. By default, the CM signal (heartbeat pattern) is 
sent at an interval of 10ms (value for HeartBeat Interval under CM PHY 
Parameters).

The eARC Differential Signal is a “Bi-Phase Mark” (BPM) coded pattern, 
which runs indefinitely. To generate an eARC pattern, the software first 
checks the Duty Cycle of the differential signal 0 and 1 bits. Then, the bit 
stream BPM-encoded pattern is mapped to the falling edge modulation, 
such that

‘1’ mapping is done to 60% duty cycle (1 mapped to 11100)

‘0’ mapping is done to 40% duty cycle (0 mapped to 11000)

To meet the CTS requirements, this ratio is set by default in the Diff DC 
area of the Generator tab. However, you may change the duty cycle 
percentage value from the drop-down options for either 0 bit or 1 bit to 
meet custom requirements.
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eARC CM Events

The eARC CM Events performs an analysis on the Common Mode 
Communication between the eARC TX (DSGA) and eARC RX using the 
Analyzer module of the DSGA. It monitors the eARC discovery process 
between DSGA and the eARC RX DUT. 

By default, the eARC CM Events window appears as shown in Figure 24.

Figure 24 Default eARC CM Events tab view

If there is no eARC RX DUT connected, the software returns “No events 
strobed” in the Audio Results area, as shown in Figure 25.
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Figure 25 Audio Results in eARC CM Events tab without DUT

eARC Common Mode Communication Protocol

Common Mode data (from DSGA) consists of a heartbeat signal. The 
heartbeat signal contains five read and five write transactions. As common 
mode communication is bi-directional, the DUT responds to the heartbeat 
signal in return. Afterwards, the DSGA analyzes the response of the eARC 
RX DUT and changes the heartbeat signal accordingly. There are two 
status registers (EARC_RX_STAT and EARC_TX_STAT) which are important 
in the common mode communication. These registers are part of 
heartbeat sequence and contain status bits. CAP_CHNG and STAT_CHNG 
bits are part of EARC_RX_STAT register, which is analyzed in the eARC CM 
Events tab. The eARC RX DUT sets the CAP_CHNG and STAT_CHNG bits 
within an interval of 100ms after the Capability data structure and eARC 
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Latency register are updated, respectively. The eARC RX DUT clears this 
bit when EARC_TX_STAT is overwritten with CAP_CHNG_CONF and 
STAT_CHNG_CONF bits, respectively.

HDMI eARC testing with an actual DUT

If you have an eARC DUT connected, the events are strobed in the Audio 
Results area (see Figure 26). You must unplug and then plug in the HDMI 
connector to the eARC RX DUT after generating the eARC signal because 
the eARC RX DUT requires an HPD toggle to enter the eARC discovery 
process. After the HPD toggle, click Start Data Analysis to see the 
communication between the DSGA and eARC RX DUT. The DSGA 
continuously outputs the heartbeat signal and eARC RX DUT response is 
shown in terms of events being strobed. An “ACK strobed” event in the 
Audio Results tab indicates that the DUT has correctly received the 
heartbeat pattern and acknowledges it. However, if a “NACK strobed” 
event is seen, it indicates some fault with the heartbeat pattern sent from 
eARC TX (DSGA).

The Audio Results area also shows “Capture and Status Bits” from eARC 
RX DUT. For entering into eARC discovery, the RX DUT sets Capture and 
Status Bits 11. The DSGA copies the status to eARC_TX_STAT register and 
outputs a new heartbeat signal. As soon as the Capture and Status bits are 
copied to eARC_TX_STAT register, the RX DUT resets it to zero.
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Figure 26 Audio Results in eARC CM Events tab with DUT connected
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eARC Tx testing

Figure 27 shows the tab that appears for eARC Rx testing, when the 
Application is selected as eARC and the Use eARC Analyzer check box is 
selected in the Instrument Connection window.

Figure 27 eARC Analyzer tab settings for eARC Tx testing

eARC TX testing functionality in the software is used to perform eARC 
discovery between the TX DUT and DSGA.

The value in Analyzer Threshold (under CM Analyzer PHY Parameters) is 
used as the input comparator of the DSGA Analyzer module. The setting of 
the threshold value is based on the DUT signal level (Amplitude) and DC 
offset value (Offset) under CM Generator PHY Parameters.
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Click Analyze Audio (at the bottom of the window) to perform eARC 
discovery between the TX DUT and DSGA.
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